Opensourcetechブログ

OpensourcetechによるNGINX/Zabbix/Neo4j/Linuxなどオープンソース技術に関するブログです。

Ansible を v2.7.4へアップグレード

 

こんにちは、LinuCエバンジェリストこと、鯨井貴博@opensourcetechです。

 

Ansible v2.7.4がリリースされたので、アップグレード!

ansible/CHANGELOG-v2.7.rst at stable-2.7 · ansible/ansible · GitHub

 

 

Changelogs

バグフィックス 1件。

Bugfixes

・powershell - add lib/ansible/executor/powershell to the packaging data

 

アップグレード

XYZ:~ Yoshiki$ pip list | grep ansible
ansible 2.7.3
XYZ:~ Yoshiki$ pip install --upgrade ansible
Collecting ansible
Downloading https://files.pythonhosted.org/packages/9e/df/b7ce359f9cc16864e0d5c9c93efe69f576fc437e74549bcc142f02cd4216/ansible-2.7.4.tar.gz (11.8MB)
100% |████████████████████████████████| 11.8MB 1.8MB/s
Requirement already satisfied, skipping upgrade: jinja2 in ./anaconda3/lib/python3.6/site-packages (from ansible) (2.10)
Requirement already satisfied, skipping upgrade: PyYAML in ./anaconda3/lib/python3.6/site-packages (from ansible) (3.12)
Requirement already satisfied, skipping upgrade: paramiko in ./anaconda3/lib/python3.6/site-packages (from ansible) (2.4.1)
Requirement already satisfied, skipping upgrade: cryptography in ./anaconda3/lib/python3.6/site-packages (from ansible) (2.2.2)
Requirement already satisfied, skipping upgrade: setuptools in ./anaconda3/lib/python3.6/site-packages (from ansible) (39.1.0)
Requirement already satisfied, skipping upgrade: MarkupSafe>=0.23 in ./anaconda3/lib/python3.6/site-packages (from jinja2->ansible) (1.0)
Requirement already satisfied, skipping upgrade: pyasn1>=0.1.7 in ./anaconda3/lib/python3.6/site-packages (from paramiko->ansible) (0.4.4)
Requirement already satisfied, skipping upgrade: pynacl>=1.0.1 in ./anaconda3/lib/python3.6/site-packages (from paramiko->ansible) (1.2.1)
Requirement already satisfied, skipping upgrade: bcrypt>=3.1.3 in ./anaconda3/lib/python3.6/site-packages (from paramiko->ansible) (3.1.4)
Requirement already satisfied, skipping upgrade: idna>=2.1 in ./anaconda3/lib/python3.6/site-packages (from cryptography->ansible) (2.6)
Requirement already satisfied, skipping upgrade: asn1crypto>=0.21.0 in ./anaconda3/lib/python3.6/site-packages (from cryptography->ansible) (0.24.0)
Requirement already satisfied, skipping upgrade: six>=1.4.1 in ./anaconda3/lib/python3.6/site-packages (from cryptography->ansible) (1.11.0)
Requirement already satisfied, skipping upgrade: cffi>=1.7 in ./anaconda3/lib/python3.6/site-packages (from cryptography->ansible) (1.11.5)
Requirement already satisfied, skipping upgrade: pycparser in ./anaconda3/lib/python3.6/site-packages (from cffi>=1.7->cryptography->ansible) (2.18)
Building wheels for collected packages: ansible
Running setup.py bdist_wheel for ansible ... done
Stored in directory: /Users/Yoshiki/Library/Caches/pip/wheels/e0/9f/50/64105336fc05fac4316cff41724ac5d6f32dab36540c7400cc
Successfully built ansible
Installing collected packages: ansible
Found existing installation: ansible 2.7.3
Uninstalling ansible-2.7.3:
Successfully uninstalled ansible-2.7.3
Successfully installed ansible-2.7.4
XYZ:~ Yoshiki$ pip list | grep ansible
ansible 2.7.4

 

 

 

 

www.slideshare.net

github.com

www.facebook.com

twitter.com

www.instagram.com

 

 

にほんブログ村 IT技術ブログ Linuxへ
Linux

にほんブログ村 IT技術ブログ オープンソースへ
オープンソース

 

 

Opensourcetech by Takahiro Kujirai